Quantcast

Combination cluster fuzes keep blowing.

The Navara Forum

Help Support The Navara Forum:

johnl56

NF Supporter
NF Supporter
Joined
Oct 29, 2020
Messages
15
Reaction score
1
Location
Tasmania
2012 D22 155K and I am having an issue with the 10amp fuse keeps blowing for my cluster. It happens intermittently and has been ok for months. But yesterday we went up to Mt Lomond in Tassie and it blew after I hit the dirt road for a bit, I changed it out at the top and on the way back down it popped again. I have made no mods apart from spotties, but it had done this before that as well. No electrical smell as you might get with a short. I am wondering about a bad earth but that would not normally cause a fuse to blow I would think, just make the cluster not work as the earth was broken. Any ideas? I am going to do a bit of a hunt today but was hoping someone might have come across this before and be able to pint me in the right direction.

Regards

John
 

Old.Tony

Administrator
Administrator
Joined
Oct 3, 2009
Messages
15,612
Reaction score
69
Location
Mid Coast Region, NSW, Australia
Try providing a separate earth point to the stereo. The head unit and instrument cluster used to share an earth point, it's possible that one or the other is drawing extra power through the fuse to compensate for the poor earth.
 

johnl56

NF Supporter
NF Supporter
Joined
Oct 29, 2020
Messages
15
Reaction score
1
Location
Tasmania
I am replacing the stereo anyway so I will do that in the next few days. It is something that happens only occasionally.

Thanks for getting back to me

john
 

amber.2

Well-known member
Joined
Jan 16, 2012
Messages
348
Reaction score
21
Location
Robina Gold Coast QLD
When i had my D22 i replaced the Single din with a radio out of a 2014 D40 , as the owner had it replaced and i picked it up for $100 . I was told by Nissan that it would never work , So with nothing to loose i wired it up and installed it and it worked with out any problems for the next 4 years till i upgraded to a JVC double din with blutooth
 

Attachments

izzibri@gmail.com

Well-known member
Joined
Jan 31, 2017
Messages
194
Reaction score
21
Location
CHESHUNT
bad earthing in multiple earths through single bolt will cause voltage drop maybee multimeter would help
 

johnl56

NF Supporter
NF Supporter
Joined
Oct 29, 2020
Messages
15
Reaction score
1
Location
Tasmania
An update to my issue I replaced the radio and gave it its own earth point on the frame in the dash. No more blown fuses so far touch wood.
 

Latest posts

Top