Quantcast

High RPM low Performance

The Navara Forum

Help Support The Navara Forum:

Fighter1

Member
Joined
Oct 30, 2020
Messages
2
Reaction score
0
I have a 2010 Navara d40, manual diesel.
Bought it 2nd hand and for the past year its been a dream. Had to replace the clutch and had the alternator rebuilt tho.

The past few days My rpm randomly spikes, while driving, and when accelerating on 4th gear from 30mph to 50mph the RPM hits 4.8k before any changes in speed.
I have honestly no idea what could cause this.
Whats make it even more confusing is that the car seems to be different each time I drive. Sometimes its almost normal, but it's getting more and more common that this rpm stuff happens. And on top of that, the fuel consumption has increased as well. I've been using one of those fuel saver chips for the OBD2 plug. Could that cause it? Any advice is more than welcome!

Thanks in advance!
/Nik
 

izzibri@gmail.com

Well-known member
Joined
Jan 31, 2017
Messages
115
Reaction score
13
Location
CHESHUNT
is it just the rev guage playing up , i had that happen to me i never fixed it it eventually stopped working , if there are other issues try dissabling the chip, i dissabled mine (put it in myself)
 

Old.Tony

Administrator
Administrator
Joined
Oct 3, 2009
Messages
15,465
Reaction score
41
Location
Mid Coast Region, NSW, Australia
I've moved the thread into here (rather than the D22 section).

This does sound like it could be a slipping clutch. You'd need to determine whether or not the vehicle's clutch is hot - the easiest way to gauge this is by recalling how much you've been feathering (slipping) the clutch yourself. Steep incline takeoffs are likely to make this worse.
 

Latest posts

Top