Egr coolent hose to block

Nissan Navara Forum

Help Support Nissan Navara Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

c2fe3

NF Supporter
Supporting Member
Joined
Sep 6, 2023
Messages
34
Reaction score
5
Location
Australia
Warning to everyone with this zd30 engine with egr system
This just happened to me there is a small hose going from the egr exhaust inlet to the block behind the starter motor.
It split leaking all coolent out of the system making the engine over heat to Max temp on gauge
Didn't realise it till I smelt the coolent smell looked at gauge was at Max high temp I pulled over let it cooled looked for the leak filled it up and went home to diagnose. Fixed the hose
Bled the system checked the functionally all working fine no bubbles or loss of coolent thermostat working fine
I'd say rocker cover leaking oil over time swelled the hose to split .
How this helps all ...
Send me your thoughts
 

Attachments

  • 20240320_160115.jpg
    20240320_160115.jpg
    1.4 MB · Views: 0
  • 20240320_160102.jpg
    20240320_160102.jpg
    1 MB · Views: 0
  • 20240320_160033.jpg
    20240320_160033.jpg
    2.7 MB · Views: 0
Yes so far but will monitor it and keep everyone posted good that you will check it you might need a strong light and a small mirror it's on the block side underneath but it's worth it đź‘Ś
 
Well it's been over a week since this happened and it looks like all is OK
No temp issued no coolent lost no pressure build up in the reserve tank no hard starting I hadn't done a compression test nor raidator test if I have issues in the near future I will do these examinations
 
Warning to everyone with this zd30 engine with egr system
This just happened to me there is a small hose going from the egr exhaust inlet to the block behind the starter motor.
It split leaking all coolent out of the system making the engine over heat to Max temp on gauge
Didn't realise it till I smelt the coolent smell looked at gauge was at Max high temp I pulled over let it cooled looked for the leak filled it up and went home to diagnose. Fixed the hose
Bled the system checked the functionally all working fine no bubbles or loss of coolent thermostat working fine
I'd say rocker cover leaking oil over time swelled the hose to split .
How this helps all ...
Send me your thoughts
Mate i'm trying to locate this hose on my ute and replace it to avoid in nasty surprises in the future. Can you please circle it in the first picture or provide some dimensions. I had a good look yesterday and sort of scratching my head as to which one it is?
 
Mate i'm trying to locate this hose on my ute and replace it to avoid in nasty surprises in the future. Can you please circle it in the first picture or provide some dimensions. I had a good look yesterday and sort of scratching my head as to which one it is?
Sorry it's between the egr section behind the injection pump and the other you just see by the starter motor behind it to the block you will see it
 
Mate i'm trying to locate this hose on my ute and replace it to avoid in nasty surprises in the future. Can you please circle it in the first picture or provide some dimensions. I had a good look yesterday and sort of scratching my head as to which one it is?
Sorry it's between the egr section behind the injection pump towards the firewall and the other part is behind the starter motor to the block you wil see it
 
Back
Top