Quantcast

Blinking MIL - ZD30DDT

The Navara Forum

Help Support The Navara Forum:

technitium

Member
Joined
Jun 15, 2019
Messages
7
Reaction score
0
Location
Wanaka, New Zealand
Hello, long time reader, first time poster

Ive got a 2002 D22 with the ZD30DDT in it.
Few months ago after a good 5hr drive my MIL started blinking, about 3 minutes from my destination. Got to where I was going, turned the ute off and didnt drive it for a couple of days. It never come back on. Since then it has become more and more common for it to turn on, now its on from cold start up.

Ive read in the service manual that its due to water detection in the fuel filter. filter is Ryco brand, Ive heard they leak and in general are just unreliable.
so Ive drained the water out, a good 500ml, do i need to do more? CO cleaned the sensor connection and then primed the shit out of it yet no cigar, still blinking.

just EGR, Swirl mod done, and intake manifold cleaned a couple of days ago as I decided Id be trailering it to the dealership anyway with the MIL blinking. So if anything went wrong, it wasnt going to be a biggy anyway. Nissan Dealership is 3hrs away so not worth the risk.

Any suggestions on what to check next? handy with a spanner, not a mechanic though.

Thanks in advance.

Edit: Last day before nationwide lockdown due to the worlds situation, Im in New Zealand, so if I can get by not buying anything that would be sweet
 
Last edited:

bods

Well-known member
Joined
Sep 17, 2010
Messages
5,066
Reaction score
13
Location
Orelia, WA
Hey mate, I've been using ryco filters on my yd25 since the warranty ran out and I haven't had any trouble. As long as you lubricate the seal on the fuel filter before fitting it you shouldn't have any trouble.

As for your issue, there are threads on here with the procedure to read the codes that cause the engine light. If you can do that it should give you an idea of what to look at.

If you drained 500ml or water out of the fuel filter, you really need to replace it asap. Or do you mean you drained 500ml of fuel out?
 

technitium

Member
Joined
Jun 15, 2019
Messages
7
Reaction score
0
Location
Wanaka, New Zealand
500ml of diesel through the draining tap at the bottom of the filter. Filter is very close to being due to change so hopefully I can sort that out soon.

Cheers for the reply!
 

bods

Well-known member
Joined
Sep 17, 2010
Messages
5,066
Reaction score
13
Location
Orelia, WA
All good, I'd be trying to get a code out of it if you can. Water should settle to the bottom of the filter, so that would have come out before any diesel. They are a pretty simple float sensor though, so that may be causing it too. The only way to tell is remove it, but you have to remove the filter to do that too...
 

Latest posts

Top