Air con switch problem - D40

The Navara Forum

Help Support The Navara Forum:

kwilko

Well-known member
Joined
Aug 5, 2011
Messages
114
Reaction score
0
Location
Thailand
My 2009 Navara 4dr 4x4 2.5 diesel has had complete new aircon fitted after the compressor disintegrated.
now the garage has phoned and said they can't get the control switch to turn the compressor on and off. It is a brand new compressor, condenser and radiator.
they tell me if they supply power directly to the compressor it works - it appears to be the switch.

any idea what the problem may be?
Any advice/fixes/etc gratefully received
 

Old.Tony

Administrator
Joined
Oct 3, 2009
Messages
15,319
Reaction score
2
Location
Mid Coast Region, NSW, Australia
The fan has to be running (setting 1, 2, 3 or 4) so if the fan resistor has failed it may prevent the air con compressor from starting. Usually only ONE of those will fail. My own resistor pack failed for fan speed 1, but I could still use it (and have the compressor running) on speeds 2, 3 and 4.


Try changing fan speed and see if that helps? if it works, the resistor pack is in the bottom of the air duct (on the left hand side in right hand drive vehicles, not sure about yours) and costs a bloody fortune from Nissan.


On eBay they're available, I bought one from there and it's lasted a long time. Here's one example, there are plenty more:


https://www.ebay.com.au/itm/Blower-...375482?hash=item4d4e9cb87a:g:9KkAAOSw4ARcv~6m
 

kwilko

Well-known member
Joined
Aug 5, 2011
Messages
114
Reaction score
0
Location
Thailand
OK thanks this is the problem my workshop has......../Users/apple/Downloads/591159804.687251.mp4.zip

that won't work so below is a screen shot
 
Last edited:

kwilko

Well-known member
Joined
Aug 5, 2011
Messages
114
Reaction score
0
Location
Thailand
It seems the garage is having no luck whatsoever with this.......I've cut and pasted your post but no luck so far
 

Old.Tony

Administrator
Joined
Oct 3, 2009
Messages
15,319
Reaction score
2
Location
Mid Coast Region, NSW, Australia
It's possibly the MAFS. It's about the size of a credit card, it sits in the hard pipe just outside the air filter box on the pipe that heads to the turbocharger. I am not sure this is used in the decision to operate the air conditioning compressor.
 

kwilko

Well-known member
Joined
Aug 5, 2011
Messages
114
Reaction score
0
Location
Thailand
Yes -seems unlikely - but they need to try anything - the vehicle is sitting there with brand new a/c system that refuses to work.
 

kwilko

Well-known member
Joined
Aug 5, 2011
Messages
114
Reaction score
0
Location
Thailand
Nearly 2 weeks and no solution. They keep testing and refitting circuits and relays..... The vehicle drives but the air won't come on.... I'm running out of patience.!!!!
I cant brlieve there us no solution to this problem.
 

Old.Tony

Administrator
Joined
Oct 3, 2009
Messages
15,319
Reaction score
2
Location
Mid Coast Region, NSW, Australia
I can't believe they're having this much trouble either.

There's a whole range of diagnostic step-by-step information in the electronic manual (look in MTC.pdf). Some of this you could check yourself. Do you have the manual? The MTC.pdf part is 4.6Mb.

Did they change over your BCM (Body Control Module) when they added the air conditioning?
 

kwilko

Well-known member
Joined
Aug 5, 2011
Messages
114
Reaction score
0
Location
Thailand
fixed - eventually the garage repaired a relay and the system is operating.
then the radio touch screen wouln't work and the turbo wasn't functioning - refitted a load of breather pipes and the power was sorted and 400 baht a t specialist car media man fixed the player screen.
now I find the headlamp leveller isn't working.
will start another thread about that.
 

Latest posts

Top