D40 STX550 Dash Instrument Lights Turning Off/On

The Navara Forum

Help Support The Navara Forum:

ra82

New member
Joined
Feb 5, 2019
Messages
2
Reaction score
0
Location
Australia
Hi,

I have a Navara STX550 D40 2013 model.

The instrument dash lights turn off randomly and then turn back on and so on. The gauges are still working but the lights are off. When they do turn back on the radio volume increases when they turn off it decreases. I have had issues with cruise control not working when dash lights resume and the "set cruise control" light flashing but not allowing me to set it. Another issue I have had is the triptronic not working or the sports mode when the lights are off or sometimes even when they are on. The map on the radio and fuel consumption does not work when the lights are off. I have also had issues with the rear windows not working on a couple of occasions. A couple of times when connecting my phone to bluetooth it would restart the radio screen.

We have taken it to Nissan whom were no help at all basically blaming it on after market accessories. They ran diagnostics but could not tell us what the issue is.
 

bods

Well-known member
Joined
Sep 17, 2010
Messages
5,034
Reaction score
3
Location
Orelia, WA
Hey mate. Apparently these have a common problem with bad instrument cluster earth's. It has been recommended on here to try adding an extra earth cable between the radio head unit chassis and the steel bracing behind the dash panel.

I would be trying that first as the cheapest option. Good luck.
 

Old.Tony

Administrator
Joined
Oct 3, 2009
Messages
15,319
Reaction score
2
Location
Mid Coast Region, NSW, Australia
As bods says, we've seen similar weird issues like that before. Try his suggestion, there are bolts that hold the dash in place underneath and are easy to find.
 

ra82

New member
Joined
Feb 5, 2019
Messages
2
Reaction score
0
Location
Australia
Thanks mate, will give this a try. I'll keep you updated on the results
 

Latest posts

Top