Aftermarket wheels causing steering wobble

The Navara Forum

Help Support The Navara Forum:

Michael10

Active member
Joined
May 24, 2013
Messages
27
Reaction score
0
Location
Wollongong
Hi all,
Have had a problem with my navara steering ever since I can remember, where the steering wheel wobbles like crazy between 80-110km, and multiple alignments and balances haven't fixed the issue. The mechanic told me it could be due to the sunraysias I have on, apparently they don't sit and lock in like the genuine nissan ones do (perfect fit, slight imbalance or something)
Can anyone shed some light onto this?
Cheers
 

happy john

Well-known member
Joined
Dec 26, 2012
Messages
4,675
Reaction score
0
Location
Brisbane Northside
The mechanic is probably correct the steelies could be the problem but don't rule out an out of round tyre or an old flat spot,did you have a lockup in the dry?.
 

Michael10

Active member
Joined
May 24, 2013
Messages
27
Reaction score
0
Location
Wollongong
The mechanic is probably correct the steelies could be the problem but don't rule out an out of round tyre or an old flat spot,did you have a lockup in the dry?.
Tyres a brand new I thought that too, got new ones but didn't fix it at all
 

mike1303

Well-known member
Joined
Sep 1, 2011
Messages
2,280
Reaction score
0
Location
Canberra
Had a mate with the same problems bud, even got new muddies to try fix it. Turns out the bottom bushes in the front shocks were worn. Have a check there
 

Ryno91

Well-known member
Joined
Jan 27, 2013
Messages
73
Reaction score
0
Location
Brisbane
had the exact same problem with my ute, it wasn't the tyres at all.. it was the rear uni joint on the front tailshaft so get that checked out. If it's only speed related it's a good chance to be a uni joint
 

lance7983

New member
Joined
Jun 14, 2019
Messages
3
Reaction score
0
Location
Perth WA
Same issue with mine, will check ball joints etc. Has anyone used centralising rings on aftermarket wheels?
 

Bambam

New member
Joined
Apr 28, 2020
Messages
4
Reaction score
0
Location
brisbane
had same issue and turned out one of the front driveshafts was on its way out. Got replaced and never had issue since
 

Nomadic Navara

Well-known member
Joined
Aug 28, 2008
Messages
64
Reaction score
0
Location
NSW Central Coast
The mechanic told me it could be due to the sunraysias I have on, apparently they don't sit and lock in like the genuine nissan ones do (perfect fit, slight imbalance or something)
Can anyone shed some light onto this?
I would not be using wheels that do not fit the hub properly. That locating ring on the hub that the wheel centre fits neatly over is there for a purpose. You are asking for trouble if the wheel does not fit snuggly on it.

Have a close look around the wheels, most of the Sunraysia style wheels I have seen that are not centre locating types have "for trailer use only" or similar stamped on them in little letters somewhere.
 

Latest posts

Top