Quantcast

D40 Radio skipping channels

The Navara Forum

Help Support The Navara Forum:

nathand22

Well-known member
Joined
Feb 14, 2011
Messages
7,359
Reaction score
0
Location
nsw
Just thought i would put up some info from another thread but under a title that is more likely to be searched for then the original.
As mentioned above the info is stolen from another thread.


Here is a link to the original thread
http://www.navara.asia/showthread.php?t=18772


D40 2012 stereo AF mode deselect fix
As per the title the stock stereo in my ST-X (also in the rest of the range now I think, and first supplied in the ST-X 550 a few years ago) has an incredibly annoying 'AF' mode.

What happens is in areas of patchy reception (like in the area I live in near Toowoomba) the FM radio hunts for a better signal of the station which is playing. While great in theory, it jumps to a completely different station all the time for some reason!

When the reception is bad the end result is that the radio jumps for a second or two every once in a while (sometimes often) to a different station.

The 'AF' mode is mentioned in the owners handbook, but no info is given how to deselect it on the non-nav systems.

I figured I would put the fix up on here, as I searched long and hard to find it! The end answer; I called the local dealer in Toowoomba who helped which just seemed too easy

Press and hold 'setup' and jiggle the 'tune' knob left and right. This brings up a hidden menu and from there you can deselect the AF mode. This way the station you are on may deteriorate in quality a little, but the radio wont hunt for a new station and drive you crazy by chopping stations automatically.

Hope it helps!
 
Last edited:

BJJ84

Well-known member
Joined
Aug 8, 2012
Messages
317
Reaction score
0
Location
Gold Coast, Australia
Brilliant! I travel between Brissy, the gold coast and Mt Tamborine regularly and Triple M is the worst for that, in really bad situations, it's clear for about 5 secs then skips to something else for about 1 sec or just under. I'll definitely have to give this hidden menu a crack!
Thanks for the repost Nath!
 

nathand22

Well-known member
Joined
Feb 14, 2011
Messages
7,359
Reaction score
0
Location
nsw
Disconnected my battery today and the radio went back to the default mode and started doing the skipping channels crap again, so had to bring up the hidden menu and turn off the "AF MODE" to make it stop.

So guys if you ever disconnect the power to the radio you will need to turn the "AF MODE" off.
 

TigerST

Well-known member
Joined
Oct 6, 2012
Messages
1,330
Reaction score
0
Location
Canberra
I think tjm turned mine off when they fitted the bar as it now has an AF in the bottom corner never noticed it before and doesn't do the jumping thing anymore.
 

Latest posts

Top