Nissan Navara Forum

Help Support Nissan Navara Forum:

A
Reaction score
2

Latest activity Postings About

    • A
      aussie nav replied to the thread Maf sensor.
      Wasn't a coolant leak, it was the hose from the intercooler to the throttle body, had a split in it causing the maf sensor to throw a...
    • A
      aussie nav replied to the thread Maf sensor.
      Back again with what I believe is the source of my priblems see attached pics one is the problem the other one is my fix all tool...
      • 20230124_121317.jpg
      • 20230124_121312.jpg
    • A
      aussie nav replied to the thread Maf sensor.
      So back again with the same problem, thought I had fixed it but 900km road trip it happened within the first 200km and now engine light...
    • A
      aussie nav replied to the thread Maf sensor.
      Whoop whoop all fixed I think, no codes equals no problems, new maf, filter, contact cleaner and coolant 😳😂😂😂😂 Thanks every one for your...
    • A
      aussie nav replied to the thread Maf sensor.
      Yeah going to test the cable with a multimeter Cheers Tony
    • A
      aussie nav replied to the thread Maf sensor.
      Yes it was mate but I suspect there maybe other things at play, when I serviced the car I used an airfilter that I never used before so...
    • A
      aussie nav posted the thread Maf sensor in D40 General Chat.
      Has any ever got this code on their navs and how did you fix it? P0113 Intake air temperature sensor circuit high D40 2008 2.5 manual...
    • A
      aussie nav replied to the thread Cruise Control, again...
      Neutral position switch
    • A
      Just joined hopping that it will be easier and quicker to maintain and repair my Nav Cheers Aussie Nav John
  • Loading…
  • Loading…
Top