Quantcast

Tillix valve settings D40

The Navara Forum

Help Support The Navara Forum:

Cobez

NF Supporter
NF Supporter
Joined
Mar 15, 2012
Messages
1,438
Reaction score
2
Location
Ferntree Gully, Victoria
Hey all,

It's been bloody ages since i have posted a thread here. Years even. So hey!!

Just fitted a Tillix valve and needle unit yesterday. I have it boosting around 19psi at 2500 revs, which is fine, but if i give it a stab to 3000 it shoots up to around 24psi, holds then drops to 15psi and holds there.

Doesn't go back to normal until i take my foot off the throttle and rev it out again.

I have the needle valve about a turn and a 1/4 off all the way in, and the Tillix valve wound out a fair way from max boost.

I really don't want my YD25 hitting 25 pound of boost regulary, and that cut out and drop down to 15psi is bloody annoying.

Anyone know what i can do to fix these two probs? Cheers all
 

Old.Tony

Administrator
Administrator
Joined
Oct 3, 2009
Messages
15,531
Reaction score
52
Location
Mid Coast Region, NSW, Australia
I don't think I've got my needle set correctly, so I can't help much there, but I just kept adjusting the chamber of the main valve until my max boost was about 21psi and that's where I am leaving mine.

Too much more than that (half a turn more) and my ECU reports an overboost.

I'd suggest winding it out so that you're producing about 16psi then go up in small stages until you're happy. That's what I did, over several trips.
 

Cobez

NF Supporter
NF Supporter
Joined
Mar 15, 2012
Messages
1,438
Reaction score
2
Location
Ferntree Gully, Victoria
Good to see you are still about Tony! It's been a while mate.

This needle is doing my head in. I want about 20psi @3000 max, i have wound the valve right out, then did the needle valve right up tight, put a black line on it with a paint pen, and did 3 full turns loose. Not TOO bad but only hitting 15psi at 2500.

I'm finding the same as you, once it hits 24 or 25 pounds the ECU cuts it and drops it back to 15 (like a mild limp mode).

Brought it back home, did the needle valve back up tight again, backed it off 2 full turns this time. Will see how it goes tomorrow on the way to work.

I don't want to piss the neighbours off too much as the Nav is quite loud on the turbo etc. Everyone's having a relaxing Sunday arvo bevvie outside so i might call it quits and do the same for today haha.

I'm not going for huge boost, i didn't buy the kit for that, i bought it for a smoother linear boost curve and a bit more driveability.

But it's testing my patience today 😂
 

Nav669

NF Supporter
NF Supporter
Joined
Aug 12, 2020
Messages
14
Reaction score
7
Location
Esperance
Just a question on boost if I may, I’ve installed a new bigger billet turbo, large intercooler and all boost hoses and at first i was really amazed at the huge increase in power over standard. I’ve since in the last month fitted a redarc boost/egt gauge and I was getting spikes of 30-35psi of boost with no ecu cut but when off road and really booting it I’m guessing (boost gauge only goes to 35) I’m getting up to maybe 40 psi and then the ecu throws a light but no limp mode.
I’m running all factory vac system and I’m thinking the engine likes the high boost as my egts under normal conditions towing a 8x5 loaded trailer only gets to 400 and really giving it to her off road maybe hits 450-500 but no more. Sorry to steal your post COBEZ.
 

Cobez

NF Supporter
NF Supporter
Joined
Mar 15, 2012
Messages
1,438
Reaction score
2
Location
Ferntree Gully, Victoria
Did you get an ECU re-tune after the bigger turbo and cooler was fitted? If so, that may explain the ECU not sensing overboost and cutting the boost down. 30 to 35psi is bloody awesome, i'd be worried if a factory turbo was spiking that high hahaha.

Tony, FYI i spoke to Lindsay from Tillix last night, he said completely close your needle valve off (thread all the way IN) then wind your boost valve all the way OUT basically until it comes apart, then wind two threads back IN and use that as your starting point.

Once you have reached your desired max boost level, THEN start playing with the needle valve at 1/8 of a turn winding OUTWARDS (opening) at a time, max. He said it's not even needed a lot of the time (the needle valve) on D40's.
 

Old.Tony

Administrator
Administrator
Joined
Oct 3, 2009
Messages
15,531
Reaction score
52
Location
Mid Coast Region, NSW, Australia
I'm actually happy with the way it's going at the moment but I might mark the device and give his settings a go and see what happens. Thanks for the info!

As for max boost etc @Nav669, it's interesting that you can get the boost that high without the ECU going bananas over it. Also, those EGT figures must be post-turbo, because pre-turbo you should be seeing 600+ degrees celcius without overboosting.
 

Cobez

NF Supporter
NF Supporter
Joined
Mar 15, 2012
Messages
1,438
Reaction score
2
Location
Ferntree Gully, Victoria
Ended up buggering the needle valve off altogether and simplifying things.

Now hitting a sensible 20lb @ 2500 and holds nicely up to 3000 with no overboost cut off from the ECU.

MUCH smoother boost curve and doesn't spool up too aggressively. Nice amount of boost, keeps the EGR's down a bit without going overboard.

As you can see in the second pic, the two ports on the factory solenoid i just short looped together for tidy's sake, and the hose from the third valve is the one you zip tie shut in the Tillix installation process, i ran that back into the airbox pipe.

One line from the main boost source at the top rear of the engine block near the injectors, down to the actuator, one T piece placed in that line, small piece of hose to the Tillix valve, longer piece to the fitting tapped into the hot side turbo pipe.

Then stand back and think to yourself that you're the smartest f****er in Australia 😂😂😂😂
 

Attachments

Nav669

NF Supporter
NF Supporter
Joined
Aug 12, 2020
Messages
14
Reaction score
7
Location
Esperance
I'm actually happy with the way it's going at the moment but I might mark the device and give his settings a go and see what happens. Thanks for the info!

As for max boost etc @Nav669, it's interesting that you can get the boost that high without the ECU going bananas over it. Also, those EGT figures must be post-turbo, because pre-turbo you should be seeing 600+ degrees celcius without overboosting.
Yer the EGT readings are off the dump pipe

ps I’ve got a full 3” exhaust no cat and hotdog muffler
 

Latest posts

Top