Stereo Wiring

The Navara Forum

Help Support The Navara Forum:

JPMC

Well-known member
Joined
Jul 30, 2009
Messages
429
Reaction score
0
Location
Christchurch, New Zealand
Has anybody removed the factory radio from an STX (or possibly an ST) and able to give me the colours for the speaker wires.

I have worked out which plug it is but for some reason I'm unable to figure out which wires are for the speakers. Normally the speaker wires are colour matched ie blue and blue with white stripe. but it doesn't appear this way on this system.

Attached is pictures of the back of the unit the unplugged white plug is the reverse camera plug and steering wheel controls.
The other white one is the main power (and speakers I'm guessing), Black is USB port and grey antenna and the blue is Navigation antenna

The close up picture is the main plug I think should be speakers and definitely is the power (large yellow wire constant power, red switched power) and earth (black wire) and the green and small yellow wire are the 3.5mm plug.
 

Attachments

Last edited:

JPMC

Well-known member
Joined
Jul 30, 2009
Messages
429
Reaction score
0
Location
Christchurch, New Zealand
Thanks but yes I have checked but the plugs they have and the versions they have don't match up to the latest setups (I'm guessing they changed it for the 2015 model) plus I'm not wanting to remove the factory unit, I just need to pick up the rear speaker outputs so I can fit an adaptor to change to low level outputs (RCA's) for my sub.
 

NP300ST

Member
Joined
Oct 12, 2015
Messages
10
Reaction score
0
Location
Melbourne
The speakers, constant and acc are all in the standard 20 pin connector.

The SWC and reverse cam are in the 32 pin.

did you work it out or would you like me to post a pic?
 

JPMC

Well-known member
Joined
Jul 30, 2009
Messages
429
Reaction score
0
Location
Christchurch, New Zealand
Thanks I worked it out.

They run a common earth which is what throw me initially.

Just incase anyone is wondering in the future, speaker wires are colour coded

Light blue - Left rear +
Brown - Right rear +
Blue - Left front +
Grey - Right front +
White - Common negitive
 

Simmo32

Member
Joined
Jan 14, 2016
Messages
13
Reaction score
0
Location
Bacchus marsh
I'm in the middle of replacing my stereo. Already have the 8" Alpine direct fit system now doin all speakers, amps and sub.

Incase anyone wants to know
Front speakers are 6x9, can also fit 6" speaker but with mdf spacer

Rear are 6", recommend also using mdf spacer if as aftermarket speakers are usually deeper
 

ktastrphe

Member
Joined
Jan 23, 2016
Messages
6
Reaction score
0
Location
perthoslavakia
The speakers, constant and acc are all in the standard 20 pin connector.

The SWC and reverse cam are in the 32 pin.

did you work it out or would you like me to post a pic?
So in theory the camera might work with an aftermarket stereo when using an aerpro style plug in harness? Awesome if so
 

ktastrphe

Member
Joined
Jan 23, 2016
Messages
6
Reaction score
0
Location
perthoslavakia
Just a follow up if anyone is interested, I (somehow) got the factory camera to work with my aftermarket stereo.
Had to tap into the factory wiring as the adapter loom they sent was for the wrong car.
Pin 59 = camera +ve image
Pin 58 = camera power
Pin 57 = camera ground (image I assume)
Pin 74 = Reverse gear selected
I bridged pin 74 and 58 so the power from the reverse signal powers the camera (although camera standard is 5.2V - not sure how long this will last)
I wired up Pin 59 as the centre of a male RCA cable and pin 57 on the outside/earth of the RCA

I do have the nissan wiring diagrams (with some scribble on it) if anyone is interested.

I should mention that initially this did not work for me, but yesterday I put the car in reverse and the camera came on! maybe one of the connections has come off and shouldnt be connected. Or maybe the heat did something. Will be interesting to see if it works long term.
 
Last edited:

Np300_D23

New member
Joined
Feb 22, 2016
Messages
1
Reaction score
0
Location
Dominican Republic
Just a follow up if anyone is interested, I (somehow) got the factory camera to work with my aftermarket stereo.
Had to tap into the factory wiring as the adapter loom they sent was for the wrong car.
Pin 59 = camera +ve image
Pin 58 = camera power
Pin 57 = camera ground (image I assume)
Pin 74 = Reverse gear selected
I bridged pin 74 and 58 so the power from the reverse signal powers the camera (although camera standard is 5.2V - not sure how long this will last)
I wired up Pin 59 as the centre of a male RCA cable and pin 57 on the outside/earth of the RCA

I do have the nissan wiring diagrams (with some scribble on it) if anyone is interested.

I should mention that initially this did not work for me, but yesterday I put the car in reverse and the camera came on! maybe one of the connections has come off and shouldnt be connected. Or maybe the heat did something. Will be interesting to see if it works long term.

Thanks... ktastrphe
Can you Put or send the other diagrams
I have the same intention and conect
The microphone, steering wheel, etc
This is my radio

https://m.youtube.com/watch?v=Z5BLrD7o8tc
 

NP300ST

Member
Joined
Oct 12, 2015
Messages
10
Reaction score
0
Location
Melbourne
I'm in the middle of replacing my stereo. Already have the 8" Alpine direct fit system now doin all speakers, amps and sub.

Incase anyone wants to know
Front speakers are 6x9, can also fit 6" speaker but with mdf spacer

Rear are 6", recommend also using mdf spacer if as aftermarket speakers are usually deeper
Do you have a pic of your sub box? There doesn't seem to be much space.
 

Simmo32

Member
Joined
Jan 14, 2016
Messages
13
Reaction score
0
Location
Bacchus marsh
No room for sub box
There is only room under back seat for 1 or 2 8" woofers depending on brand. I have made mine and fitting very soon. Will post pictures and if anyone is interested can make more
 

benchrisfennell

Well-known member
Joined
Feb 17, 2013
Messages
553
Reaction score
0
Location
melbourne australia
No room for sub box
There is only room under back seat for 1 or 2 8" woofers depending on brand. I have made mine and fitting very soon. Will post pictures and if anyone is interested can make more
I have a sub behind my back seat in a steel box. 8 inch works perfectly
 

rastik86

Well-known member
Joined
Jan 26, 2014
Messages
895
Reaction score
0
Location
Doreen,VIC
Pin numbers
I got an Alpine Halo 9 head unit hooked up and working perfect... only thing is now the rear seatbelt detectors don’t work... is it by chance the blue plug in the back of the stock unit is the detector indicator output? And if so does anyone have the PIN numbers for this???

Will post photos and extra info on the install when i can get some photos in the day time
 

Latest posts

Top