Quantcast

Problem with my Datsun

The Navara Forum

Help Support The Navara Forum:

pinto

Member
Joined
Aug 15, 2016
Messages
8
Reaction score
1
Location
Drake NSW
Help needed .. My Navara with VG30E fuel injected engine has developed a flat spot on acceleration . When cold it runs like a carburetor engine with a huge flat spot and the flat spot is still there when hot but not as bad. I have cleaned the maf sensor , air filter etc Any ideas as to the problem ?? Cheers
 

Attachments

KevinE

Well-known member
Joined
Dec 4, 2011
Messages
431
Reaction score
2
Seeing as it runs off a distributor, have you checked the spark timing? If that's out, everything is out. It's pretty easy to check using an old fashioned timing light.
 

erol ashık

New member
Joined
Mar 11, 2020
Messages
4
Reaction score
0
Location
turkey
Help needed .. My Navara with VG30E fuel injected engine has developed a flat spot on acceleration . When cold it runs like a carburetor engine with a huge flat spot and the flat spot is still there when hot but not as bad. I have cleaned the maf sensor , air filter etc Any ideas as to the problem ?? Cheers
Is it a Datsun B210 ?
 

Old.Tony

Administrator
Administrator
Joined
Oct 3, 2009
Messages
15,463
Reaction score
39
Location
Mid Coast Region, NSW, Australia
Timing is definitely a possibility, but also consider the timing advance - it may be sticking, and not advancing quickly like it's supposed to. Older distributors had a pair of weights on an arm that spun under the rotor that would swing out and change the position of the points (thus advancing the timing). Easiest way to test this is with a timing light. It might be as simple as adding some WD40 to the workings in the distributor and if that works, consider disassembly + cleaning + replacing any worn/corroded parts.
 

Latest posts

Top