lose of power

The Navara Forum

Help Support The Navara Forum:

Evan Emerton

New member
Joined
Dec 1, 2019
Messages
3
Reaction score
0
Location
regents park QLD 4118
hi guys

ive just joined this awesome site and was hoping you might be able to help, I have a D40 STX 550 2012 model and have been experiencing power lose and no fault codes coming up, if I turn the truck off and leave sit for a few seconds and re-start it runs fine again, please help
 

Old.Tony

Administrator
Joined
Oct 3, 2009
Messages
15,319
Reaction score
2
Location
Mid Coast Region, NSW, Australia
It sounds like the SCV fault that those of us with YD25 D40s experience, but I don't know if the V9X has an SCV.

The first thing I'd try is a bottle of good cleaner (Liqui Moly Fuel System Treatment is the one I use) and drive the car for 100km or so. If that doesn't work, the SCV (if there is one) may be faulty - hopefully someone with a V9X will come see this and tell us if it has an SCV or not! However, the fuel system cleaner can never hurt the car, it's worth a try!
 

spiezzy

Well-known member
Joined
May 7, 2012
Messages
77
Reaction score
0
Location
helensburgh
Hi Old Tony and Evan yes the V9X does have a SCV its on the fuel pump and your problem evan sounds like it could be that its not a hard thing to change with the write tools you will have to remove the couple of brackets and the intercooler hose to the turbo near the air filter box
Navara Parts in Melbourne sell the SCV for $189 you can also find them on eBay
hope this helps
cheers Pete
 

spiezzy

Well-known member
Joined
May 7, 2012
Messages
77
Reaction score
0
Location
helensburgh
oh and one other thing if you do order one the gasket is sold separately I think is around $14
 

Evan Emerton

New member
Joined
Dec 1, 2019
Messages
3
Reaction score
0
Location
regents park QLD 4118
Hi mate thanks for the reply and info totally appreciate it, I got my car back from my mechanic today after he had it over night running fault codes, the faults he was getting back was from the foot throttle control yes the one near the break peddle Lol, I have had a pedal torquit and chip installed some 18 moths ago, we have removed them both as the chip was also causing the car to idle like an old MF tractor, today all is good with the car ill see how she goes over the coming days and report back. cheers
 

Evan Emerton

New member
Joined
Dec 1, 2019
Messages
3
Reaction score
0
Location
regents park QLD 4118
well its been 5 days since I got my car back, chip and peddle control removed and my car is running like a dream with no issues so far, the now stock truck is very noticeable with the things removed a lot less power and response, will now have to look at a re-map????
 

landmannnn

Active member
Joined
Sep 24, 2016
Messages
36
Reaction score
0
Location
UK
A remap is about the most reliable way to gain power increases. Saying that people have even had problems with remaps causing other problems on the V9X.
If you go that route, make sure they are willing to undo the remap if needs be.
 

spiezzy

Well-known member
Joined
May 7, 2012
Messages
77
Reaction score
0
Location
helensburgh
Hi Evan Glad you got it sorted i had a chip and throttle control on my STX550 and removed them i really don't think they need it runs brilliant with out them
 

Latest posts

Top