Looks like a bad CV joint.

Nissan Navara Forum

Help Support Nissan Navara Forum:

Joined
Jul 11, 2022
Messages
31
Reaction score
7
Location
Riverina, NSW
Checking out the steering and suspension on my D40 2010. Doesn't look great. Would explain the clicking sound when accelerating and turning?

image0.jpeg

image1.jpeg

image2.jpeg

image3.jpeg
 

Horatius

Misanthrope
Joined
Sep 30, 2016
Messages
729
Reaction score
193
Location
Aus
Usually they lose the grease when the rubber boot splits, but yours looks ok (from what I can see)? If so there's a fair chance that would be your noise, they don't last long without grease.
 

Old.Tony

Administrator
Staff member
Administrator
Joined
Oct 3, 2009
Messages
16,976
Reaction score
485
Location
Mid Coast Region, NSW, Australia
In the long run, it's not going to cost a lot to replace the joint. You could pull the boot back and inspect the spider, but all that grease outside the boot tells me that either it was massively overpacked before and it's just oozed out during use, or the boot is now loose and the CV is shedding.

With the car on jack stands and steering turned full lock, you could stick your ear right near it and listen.
 
Joined
Jul 11, 2022
Messages
31
Reaction score
7
Location
Riverina, NSW
Cheers guys,
I ended up replacing both left and right cv axles and diff seals. The inner boot clamp was a bit loose and had a small crack and I wasn't in the mood to mess around with repacking the joints and replacing the boots. There was probably no need to replace both but I prefer doing things in pairs.

The last thing on the list is the Nav is pulling an erg valve open code, this is intermittent so I am guessing the valve has a bit of carbon build-up. The question is whether to clean it or blank it.

Thanks again.
 

Latest posts

Top