Error code 77 injector pump

Nissan Navara Forum

Help Support Nissan Navara Forum:

Caleb

Member
Joined
Nov 9, 2022
Messages
3
Reaction score
1
Location
Western australia
Hey I’m a new navara owner, 2006 D22 ZD 30 single cab. Engine light has come on about 10 minutes after start up but runs fine. Did a error code read and it’s saying injector pump timing error code 77

I’ve changed the fuel filter and it drives fine. I did install a 3inch system on the old girl several weeks ago but struggling to see how this could be related.

Does anyone have any advice for me? Hope I don’t have to change this out.. the cars just clocked 200k cheers
 

tweak'e

Moderator
Staff member
Joined
Oct 21, 2008
Messages
5,313
Reaction score
203
Location
New Zealand
first thing is to check for air being sucked into the fuel line. fit a bit of clear fuel hose and look for bubbles.
common cause is the fuel filter as people tend to not change the bottom o ring. also the primer itself is know to leak.
also check its the right filter some companies list the wrong one.
 

Caleb

Member
Joined
Nov 9, 2022
Messages
3
Reaction score
1
Location
Western australia
I have changed the primer pump which was faulty, and car is now running ok. Engine light still comes on after about 10 minutes of driving.

error code is injector pump timing. Called a diesel injection specialist and they said this is the early signs of the pump needing replacement. 5k.. Has anyone else experienced this and is it likely to be the pump or something a little less expensive!!

CHeers
 

tweak'e

Moderator
Staff member
Joined
Oct 21, 2008
Messages
5,313
Reaction score
203
Location
New Zealand
I have changed the primer pump which was faulty, and car is now running ok. Engine light still comes on after about 10 minutes of driving.

error code is injector pump timing. Called a diesel injection specialist and they said this is the early signs of the pump needing replacement. 5k.. Has anyone else experienced this and is it likely to be the pump or something a little less expensive!!

CHeers
yes it can be the pump but the most common issue is blocked filter or sucking air in.
the code is simply that it cannot reach proper timing. the injection timing control is powered by the injection pump internal fuel pressure, eg hydraulics. if the pump is worn it won't make enough pressure to run the timing correctly. but fuel flow restriction, which also includes air in the fuel, will also alter the fuel pressure, which alters the timing.

so check for air leaks with a clear bit of fuel hose. makes sure there is no bubbles. air can build up in the filter and then get sucked through all at once.
people have found things like cracked hose ends.
 

dpcindustries

Member
Joined
Nov 13, 2022
Messages
3
Reaction score
2
Location
Thomastown Victoria
Hey I’m a new navara owner, 2006 D22 ZD 30 single cab. Engine light has come on about 10 minutes after start up but runs fine. Did a error code read and it’s saying injector pump timing error code 77

I’ve changed the fuel filter and it drives fine. I did install a 3inch system on the old girl several weeks ago but struggling to see how this could be related.

Does anyone have any advice for me? Hope I don’t have to change this out.. the cars just clocked 200k cheers
 

Attachments

  • IMG_5964.MOV
    26.3 MB

dpcindustries

Member
Joined
Nov 13, 2022
Messages
3
Reaction score
2
Location
Thomastown Victoria
Try your plugs and clean them. I had the same problem and it went on for weeks, got it towed twice. I was ready to give up on it.
It had been at the mechanics for months and got a new injector pump, timing chain and cost a fortune. Then it ran for 2 weeks and started doing what your describing. I was over it. Had the 77 pump code, the cam sensor code and once a turbo pressure or something.
 

Latest posts

Top