D22 hissing sound in the cabin when A/C is turned on

The Navara Forum

Help Support The Navara Forum:

VB69

New member
Joined
Dec 1, 2014
Messages
3
Reaction score
0
Location
Australia, NSW, Sydney
Hi all! Have 2012 D22 Nav, 80,000km. Recently noticed a hissing sound in the cabin when I turn the A/C on. Sound appears to come from behind the A/C switch on the dash and the air isn’t cold. Was wondering if anyone has had this problem in the past?
 

izzibri@gmail.com

Well-known member
Joined
Jan 31, 2017
Messages
228
Reaction score
28
Location
CHESHUNT
old post
#2 Feb 27, 2012

It's normal for A/C to make noise when you engage it. If you open the window, you'll probably find that the noise is coming from outside, not the glove box area. Mine makes a loud hiss, followed by a grunt/moan when it's engaged, but then goes silent. AFAIK, it's the compressor spinning up that makes that noise. .
if its not getting cold you the heater water valve may bestuck open or have a disconnected or broken control link
 

izzibri@gmail.com

Well-known member
Joined
Jan 31, 2017
Messages
228
Reaction score
28
Location
CHESHUNT
do a search above type in hissing sound behind dash," if air is not cold check the cables behind knobs could be disconnected or retainer latch broken.. also heater control( water) valve staying fully open
 

Horatius

Well-known member
Joined
Sep 30, 2016
Messages
368
Reaction score
36
Location
Aus
Hi all! Have 2012 D22 Nav, 80,000km. Recently noticed a hissing sound in the cabin when I turn the A/C on. Sound appears to come from behind the A/C switch on the dash and the air isn’t cold. Was wondering if anyone has had this problem in the past?
My far older Nav (approaching 400k kms) has always made some weird ass noises with the a/c on lol. It's actually funny to have someone in the car who isn't used to it go "wtf was that?!" when it happens lol. It's always been cold though.

If it has only just started on yours and it isn't getting cold, especially of it is a more constant hissing sound, it could indicate a leak in the evap or pipes? It might be worth getting a pressure test which would involve reclaiming the gas (if any) and pressurising the system to see if it holds steady.

Could be worth checking other basic things first though (such as post above) because weird noises in a/c isn't that unusual and could happen for a lot of reasons. Is there much air coming out? I know the evaporators can block up (no filter afaik?), but if everything seems ok, might need to start thinking possible leak somewhere.
 

Horatius

Well-known member
Joined
Sep 30, 2016
Messages
368
Reaction score
36
Location
Aus
If you mean the low pressure line, yes looks like it has access through a valve near the firewall (h/p one is near condensor). Could probably check pressure there if he knows a fridgie with gauges.

Was probably wrong in the post above, its more common to pump the system into a vacuum (rather than pressurise it) and see if it maintains it. At any rate they would do before re-gassing. The leak will probably be obvious if it can be heard.

Sounds as though his system might have a leak anyway, if everything else is ok and it's not cooling.
 
Last edited:

VB69

New member
Joined
Dec 1, 2014
Messages
3
Reaction score
0
Location
Australia, NSW, Sydney
Thanks for the replies guys. Mine used to do the grunt/moan sound when first activated but then went silent and the air was cool. No grunt/moan sound anymore and no cool air but there is plenty of air coming out so no blockages, which is one good thing. Mentioned the issue to my mechanic and he referred to a valve that you guys mentioned behind the dash. Stated pipes can pop off. Just gotta get up under the dash and look for it or take to aircon specialist. Thanks again. I’ll update when resolved.
 

Latest posts

Top