Nissan Navara Forum

Help Support Nissan Navara Forum:

oldjoe
Reaction score
2

Latest activity Postings About

    • oldjoe
      oldjoe replied to the thread ANGEL EYES.
      Could they be worse than the original headlights? I don't know about any other ute headlamps, but the D40 would have to be down there...
    • oldjoe
      oldjoe replied to the thread Rims and Tyres.
      You need to know PCD of studs (should be the same), wheel diameter, offset of wheels, and tyre size. Once you have that info go to this...
    • oldjoe
      oldjoe replied to the thread New member.
      Maybe the difference in kms is because I drive slow; tow my escape capsule to remote places; then only return home when the wife has a...
    • oldjoe
      oldjoe replied to the thread D40 loss of power/limp mode..
      Yes, done that. Still going through some of the other 'improvements' I have installed looking for any bad connections or deterioration...
    • oldjoe
      oldjoe replied to the thread D40 loss of power/limp mode..
      Further info. Have tested the system with an OBDII to RS232 interpreter and no stored faults show up, No fault lights indicated during...
    • oldjoe
      oldjoe replied to the thread D40 loss of power/limp mode..
      Oldjoe again. Have searched the Nissan Navara workshop manual for any electrical connection to the stop light circuit that may provide...
    • oldjoe
      Looks like I am doing everything back-to-front!! Have posted a query before introducing myself :) I am new to forums so forgive me. I...
    • oldjoe
      oldjoe replied to the thread D40 loss of power/limp mode..
      Good question :). It is the 2.5 litre 4 cylinder turbo.
    • oldjoe
      Hi all, Oldjoe from WA here for the first time. Have read a lot of posts regarding the above issues and I have suffered this problem...
  • Loading…
  • Loading…
Top